POJ - 1751Highways (最小生成树)

要须心地收汗马,孔孟行世目杲杲。这篇文章主要讲述POJ - 1751Highways (最小生成树)相关的知识,希望能为你提供帮助。
题干:
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you cant reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 < = N < = 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i  th  town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 < = M < = 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 
Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output
1 6
3 7
4 9
5 7
8 3

题目大意:
      首行给出N,代表有1~N共N个点。接下来N行,每行两个数x,y,代表第i个点的坐标。接着给出M,接着M行,每行两个数x,y,代表第x个点和第y个点已经联通(即x到y的权值为0),建立最小生成树,输出生成树中权值不为0的边的两端的点的编号。
思路:最坏的情况需要遍历图中的每一条边,很明显的稠密图,优先选用普利姆算法。 
建图:根据坐标建立无向图,权值设为距离的平方即可,这样可以避免sqrt后权值变为double型,避免精度损失。对于已联通的两点,更新这两点的权值为0即可。 
输出边:技巧看代码。
AC代码:
  prim算法:
#include< iostream>
#include< algorithm>
#include< stdio.h>
#include< string.h>
#include< math.h>
using namespace std;
//普利姆,注意建图技巧
const int maxn=751;
const int INF=0x3f3f3f3f;
int map[maxn][maxn];
int dis[maxn];
int vis[maxn];
int Edge[maxn]; //i到Edge[i]是一条生成树内的边
struct node

int x;
int y;
Point[maxn]; //第i个点的坐标
int N; //点的数量
int M; //更新边的数量
void init()

scanf("%d",& N);
for(int i=1; i< =N; i++)//建图

scanf("%d%d",& Point[i].x,& Point[i].y);
for(int j=1; j< i; j++)//为什么这里不取sqrt,因为完全没必要
map[i][j]=map[j][i]=(Point[i].x-Point[j].x)*(Point[i].x-Point[j].x)+(Point[i].y-Point[j].y)*(Point[i].y-Point[j].y);
map[i][i]=INF; //自己不可能到自己

scanf("%d",& M);
int x,y;
while(M--)//更新图

scanf("%d%d",& x,& y);
map[x][y]=map[y][x]=0;

memset(vis,0,sizeof(vis));
vis[1]=1;
for(int i=1; i< =N; i++)

dis[i]=map[i][1];
Edge[i]=1; //初始化为存储i到1的边


void Prim()

for(int i=1; i< N; i++)

int minn=INF;
int point_minn;
for(int j=1; j< =N; j++)
if(vis[j]==0& & minn> dis[j])

minn=dis[j];
point_minn=j;

vis[point_minn]=1;
for(int k=1; k< =N; k++)
if(vis[k]==0& & dis[k]> map[point_minn][k])

Edge[k]=point_minn; //这里是输出方式的技巧
dis[k]=map[point_minn][k];

if(map[Edge[point_minn]][point_minn])
printf("%d %d\\n",Edge[point_minn],point_minn);


int main()

init();
Prim();
return 0;

/*
题意:首行给出N,代表有1~N共N个点。接下来N行,每行两个数x,y,代表第i个点的坐标。接着给出M,接着M行,每行两个数x,y,代表第x个点和第y个点已经联通(即x到y的权值为0),建立最小生成树,输出生成树中权值不为0的边的两端的点的编号。

思路:最坏的情况需要遍历图中的每一条边,很明显的稠密图,优先选用普利姆算法。
建图:根据坐标建立无向图,权值设为距离的平方即可,这样可以避免sqrt后权值变为double型,避免精度损失。对于已联通的两点,更新这两点的权值为0即可。
输出边:技巧看代码。
*/

 
【POJ - 1751Highways (最小生成树)】克鲁斯卡尔:
#include< iostream>
#include< cstdio>
#include< cstring>
#include< cmath>
#include< algorithm>
using namespace std;
int f[10000 + 5];

struct Node
double x,y;
node[10000 + 5];

struct Node2
int s,e;
double c;
node2[1000000 + 5] ;
int

    推荐阅读